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Introduction

The Vic-20 Emulator & Debugger focuses on features that help explore the Vic-20 hardware or at
least it helped me understanding the machine better than I did 20 years ago. The internal structure of
Java program resembles the hardware structure, which is not best for performance, but has other
benefits with regard to program analysis and modularity.

If you just want to fire up an emulator and play a few old games there are certainly better and more
complete alternatives, e.g. Vice' or MESS?. Also for writing small programs Vic20 CBM .prg
Studio’ may be provide all you need. Finally, you need a decent PC to run the emulator at
reasonable speed.

So why did I feel the urge to write another emulator, if there are so many better alternatives?

First, vic20emu is written in Java, so it supports a wide range of host platforms. It should also be
possible to port it to platforms like Android, first results are promising.

Second, I want a modern without a user-interface that is too close to original debuggers on the Vic-
20.

Third, I need a debugger that can be started from the development environment with symbols
loaded and ready to run my program.

Getting Started

When you start the emulator for the first time, you have to arrange the windows to your needs.
Window positions are saved, when you close the application via Exit in the file menu (see Figure 1).
Select Run from the CPU menu and the emulator starts running.
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Figure 1: The main windows of the emulator. Close any of the four windows to close the
application. Use 'Exit' from the File menu in order to store window positions.

The four main windows of the emulator are the Console window and three peripherals windows for
screen, keyboard and joystick.

1 http://www.viceteam.org/
2 http://www.mess.org/
3 http://www.ajordison.co.uk/
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Vic Output (screen)

The window displays screen output from the VIC once the CPU is running. The status bar at the
bottom of the window shows running state and frequency of the emulated CPU.

=2====2=2 EYTE= FREE
READIXY o

You can use your PC keyboard to type text, when the window is active and you can paste text from
other sources into the Vic-20 keyboard buffer, by clicking the right mouse button inside the window.
The numerical keypad and right Ctrl emulate the Joystick.

Vic Keyboard

The keyboard window is an imitation of the Vic-20 keyboard. You can use it for keys that are not
present on the PC keyboard.

| £ | Vic Keyboard

CLR INST
HOME DEL

RESTORE

RETURN

eys are locked by clicking them with the right mouse button and unlocked by right-clicking them
again. This is useful if you want to press multiple keys at the same time or want to freeze keyboard
state while hitting a breakpoint.
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Vic Joystick

The Joystick window has four small circles for the joystick positions in the
outer circle and a circle in the center of the window that shows the state of
the fire button.

Move the mouse cursor to the inner circle to "steer" the joystick by the
position of the mouse pointer. Click the right mouse button to "fire".

Console

The console window contains menus to access commands and windows and the Debug Shell that
shows CPU messages and a command interface (edit field at the bottom). You do not have to use
text commands, because for most functions are accessible from the menu or the debugger window.

|£ | Console { - = é

File Edit CPU Window Help
Debug Shell

e AMC X Y Flags SE  Stack

£

From the File menu you can load files into Vic-20 memory or store memory contents to files in
different formats.

The Edit menu is used for command interface input.
The CPU menu lets you start, stop and reset the CPU.

The Window menu is used to access other useful windows, like configuration, memory, and the
debugger window.

| £ | Console { = | = \&I
File Edit CPU |Window | Help
Debug Shell Memory

BC RAC X Y
. Configuration

o

Debug
IEC Log
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Running a Program

You can load programs directly to memory or use the disk
emulation for loading them in the emulator. In both cases you have
to select the memory configuration for the program to run. Open the
configuration window from the Window menu and set the memory

layout appropriately.

Initially all external memory areas are switched off. If you set an
area to ROM, the Vic-20 cannot write to it, but you can still load

files to memory from the File menu.

[£] Configur...l == X

Memory configuration

Empty
3k: 0400-OFFF

8k: 2000-3FFF
8K: 4000-5FFF
8K: 6000-TFFF
8k: ADDO-BFFF

 w e @ e

ROM RAM

OO0 000
OO0 0O0Co0

The Open command from the file menu lets you select a file from your filesystem and tries to guess

start address, size and format, if possible.

For example, the parameters of the file
"dragonwing.prg" are guessed correctly after
selecting it with the "Browse..." button. The last
option "Relink BASIC program" is necessary for
BASIC programs that are loaded to a different
address.

|£ | Load

Browse... I

Memory File  [20PROGSDITEST\dragonwing.pro| I

4097 |

Start Address

Block Size  [3135 |

_» Raw data

® Address as header (.prg)

) PC64 format (.P0OO)

) Phau Zeh saved session (.s20)
) PCVIC system snapshot {.pcv)
) CCS64 cartridge image (.crt)
[] Relink BASIC program

| OK

1
| || Cancel :

After loading the program to memory you can switch to the Output window, type RUN and hit
Enter to start this great program written by Aleksi Eben. (Unfortunately, the emulator does not play

sound yet)

| =] Vic Qutput - - e &

Running

" T Clocki809.37dkHz

Figure 2: Dragon Wing running in the emulator.
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The Debugger Window

You can access the debugger window from the Console (Window menu).

- -+
Z = | O] S
O ‘ ‘,J & | Wi | [ profile
AC X Y Flags 5P Cycle
| |soo [ [[soa | [ - = | |57 | [7a5571731 |
TYA |~
CLI
CLC
RT3
42 E7 L_ESES: ISR L_E742 ; Input From Eeyboard
6 L_ESES: LDA  §00CE
cC STA  $00CC -
92 02 STA  §0292 =
F7 BEQ L_ESES
SET |
[§F4] 0D |~
[$F5] O& =
[$F6] ELl1 [J3R] #=$EL0F behin H
[§F8] C564  [JSR] *=40562 inlintz =
L

Here you can
— Control execution
— Search for code locations (addresses and labels)
— Load symbols
— Enable profiling and view profiling results
— Review and modify register values
— Browse through code
— Set and clear breakpoints

— Navigate to return addresses on the stack.

1 | = 2

You can start and stop execution as well as single step through the program by using the buttons in
the toolbar. The arrow pointing down steps into subroutine calls and interrupts, whereas the straight
arrow stops execution after returning from a JSR. The up arrow stops after the next RTS/RTI.

Another way to control execution uses the context menu. Click the right mouse T
button inside the code area and a menu pops up.
Scroll to PC
Using this menu you can continue execution until it reaches the selected line, or Set breakpoint
set and clear breakpoints. Clear breakpoint
Unassemble

Breakpoints are marked by a red bullet to the left of a code line and can also be set or cleared by a
double click in that area. (The black triangle marks the position of the program counter.)

@ 153F 4C DS 14 IJMP  [nxthlk
--|1542 20 17 12 prolog: J3FE  read config

1CcAC A0 T O1a Tom FRURE G e
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Right next to the command buttons is the search box. You can enter a label or an address and hit
enter or the search button to navigate to the corresponding locations in memory. (Hex numbers need
a'$' in front, e.g. SFFD2). If the debugger can not find the label or address the search box turns
orange.

Suyeh
With the "Sym"-Button, you can load symbol files with labels (e.g. from cc65).

l[l_l [ ] profile

Bl 1z ooooz
" " . . | 1523 EE EB 14
The checkbox labeled "profile" enables execution profiling. Bl 156 e Broowll:
When enabled, the debugger displays a blue bar every row Bl ises Do ooz
. . . . 1524 E6 DC
in the code window. The width of the bar correlates with I.EUunt: 6109 Cydles. 18303 Avg. Cycles. 2
how often the statement was executed. Move the mouse Bl 52 cs o
pointer over the bar to get more results as a tool tip. Ml 1550 ponc
| 1532 A5 DB
| 1534 C5 DD

You also get a tool tip when you move the mouse pointer over the operand of a statement. For
example, the operand "curblk+3" of the statement STA has the tooltip "($14BB) -> $17.

8D EE 14 STh  curblk+3
A0 00 LDY  #500
A9 55 Erxthyr: LDA  #555 (814BB) = $17

$14BB is the value of curblk+3 and the target address of the store command STA. The current value
at address $14BB is $17. This is useful, if you step through code and want to know what is going on
in the next step without looking for the correct locations in the memory window.

2 PC AC X Y Flags sP Cycle
sis3r | |s1r szz Jses || - | [ses | [eg7err |

The second toolbar shows register values, stack pointer and CPU cycles elapsed since starting the
emulator. Red text color indicates that a value has changed since the last break. You can change
each of the values, but not the cycle count.

[$E7] 40
[$ES] EEB3 [INT]
[$EA] EEC4 [T5R] second+2

[$EC] F&EB [T5R] $FEED
[$EE] F3ED [T5R] close+l00

The stack list in the bottom of the debugger window shows the annotated stack contents. Entries
marked with [JSR] or [INT] are pushed by a JSR statement or Interrupt respectively. You can scroll
to the corresponding location by double clicking the line in the stack list.
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The IEC Window (Debug IEC)

The IEC simulator emulates the communication protocol of
Commodore's serial bus. Every byte sent over this bus is logged in
the "Debug Log" of the IEC window. Commands bytes are
marked by '/' and the commands shown in plain text.

The upper part of the window lists the configured devices on the
bus. You can add and remove devices and edit their properties by
clicking into the table.

At present, the emulator supports two devices: printer and disk.

Printer is like null device that "consumes" every byte and
discards it immediately.

Disk is a file system driver that supports reading files (including
"$") from the local file system.

Arndt Miihlenfeld 8/10

=] Debug TFC_ =Sk
Devices
En| # Type File
Cd 4|printer (null}
V] 8ldisk

‘ Add || Remove
AN
Debug Log

-=/28 - LISTEN #3
-=/F0 - OPEN #0
-= 56 -

-= 49-7T

-= 4E -

-= 2E-"

= 43-C

-= 46-F

= 47 -G

-=[3F - UNLISTEM
-= /48 - TALK #8

-= /60 - OPEN CHNIDATA #0
-=/28 - LISTEN #3
-=/E0-CLOSE#0
-=[3F - UNLISTEM
-=/28 - LISTEN #3
-=[EF - CLOSE#15

[ ] Log state Clear log
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Startup Scripts

You can use the commands of the debugger console to setup the emulator for the program you want
to run or debug. To get a list of available commands type 'help' into the command input line at the
bottom of the console window.

File Edit CPU Window Help
Debug Shell

i
]
[»

-

You get help for a specific command by typing 'help' followed by the command. To run a specific
configuration, write the commands into a file and start the emulator with the file name as parameter.

For example, take a look at the startup script I use to debug VIN*:

go til ready
wait

set ram 1
set ram 2
set ram 3

load code ../vin/diskmenu.prg
load symbols ../vin/diskmenu.lbl
sys prolog

go til prolog

wait

break set panic2

'go til' tells the emulator to run until it hits the given address or label. 'ready’' is defined in the ROM
symbol table (vicrom.sym) as

cd74 ready Restart BASIC

Since the console continues executing commands after 'go’, we have to use the 'wait' command to
wait until the CPU stops running. The Vic-20 has finished its initialization and is ready for loading
programs. First, the script enables RAM in banks 1-3 ('set ram') and loads the program ('load code')
and its symbols from ca65 ('load symbols').

The programs symbol file defines the symbol 'prolog', which is the entry point of the program. The
command 'sys' writes the BASIC 'SYS' command to the keyboard buffer and with 'go til' and 'wait'
we let the CPU reach 'prolog'.

VIN has an error routine that quits the program and prints register values and stack values. While

4 http://code.google.com/p/vin20/
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debugging I prefer to have a breakpoint instead. The last line of the script sets this breakpoint on a
location in the error routine ('break set').

After starting the emulator with the script described above, the PC points exactly the entry point of
my program and the debugger is ready to run.

(£] Vic Output = N S ——

Tl Console NN =1 (=T [5<H]

File Edit CPU Window Help
Debug Shell
Running C:\Users\Arndt\workspace\vin\vin.debug...
CEU: break at $c474
CPFU: break at $1542
Done.
EEEEE@@@ BC AC X ¥ Flags SP Stack
1542 00 00 00 = F7: 43 E1 E8 C7 79 CH
20 17 12 J5R $1217

| Clock: 727

' e ————— A ———————————— i
— —— R e —
£ Debug S — -] ——
_IKIEIENY 2| [sa] || Ciorone
AC X i Flags sp Cycle
| [s00 [s00 00 [ | JsE7 | 634837 |
D0 D6 ENE [Brnxtbyt =]
L9 BS Bendmen: LDA  #5E8 =
A2 14 LY  #514 I
20 F1 13 ISR maddram
40 DS 14 JMP  @nxthlk
20 17 1z prolog: TR read confiyg
20 E3 13 JEE cploader
20 BC 14 ISR initmen
20 9E 27 ISR initfntd
20 89 12 ISR scandrives ~|
43 [l
El 1
[5FA] C7E3 [T5R] *=50TET gonet+s | 3
| [$FC] Ce79 [T5R] *=50677 clear+zs ]
e 3
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